Back to overview
Degraded

Temporary Unavailability of Encrypted Workspaces on Android & iOS

May 19, 2026 at 5:30pm UTC
Affected services
s3.north-drive.com
app.north-drive.com

Resolved
May 19, 2026 at 11:07pm UTC

iOS encrypted workspaces have now also been fully restored and are available again.

Please make sure your app is updated to the latest version (v1.1.2) through the App Store to ensure everything works correctly.

All services should now be operating normally again. Thank you for your patience and understanding during the maintenance period.

Updated
May 19, 2026 at 7:33pm UTC

Android encrypted workspaces have now been restored and are available again.

To continue using encrypted workspaces, please update your app to the latest version (v1.1.2) through the Google Play Store.

Thank you for your patience during the maintenance period.

Created
May 19, 2026 at 5:30pm UTC

Encrypted workspaces are temporarily unavailable on Android and iOS while we perform maintenance and UI improvements.

Your data is still accessible via the web platform.

We’re working to restore full functionality as quickly as possible. Thank you for your patience and understanding.