Back to overview
Degraded
Degraded Performance on Storage Nodes
Apr 15, 2026 at 5:22pm UTC
Affected services
s3.north-drive.com
Resolved
Apr 15, 2026 at 5:32pm UTC
The performance issues affecting a subset of storage nodes have been fully resolved. All systems are now operating normally, and upload and download speeds have returned to expected levels for all users. We will continue to monitor the platform to ensure ongoing stability.
Affected services
Created
Apr 15, 2026 at 5:22pm UTC
We are currently experiencing reduced performance on a subset of storage nodes. As a result, some users may notice slower upload and download speeds. Our team is actively working to resolve the issue and restore full performance as quickly as possible.
Affected services