Partial S3 Service Disruption
Resolved
Apr 10, 2026 at 4:21pm UTC
The issue affecting a subset of storage nodes has been fully resolved. All systems are now operating normally, and data access has been restored for all users. We will continue to monitor the system to ensure stability.
Affected services
Updated
Apr 10, 2026 at 4:02pm UTC
We’ve identified an issue affecting a subset of storage nodes, which may cause some data to be temporarily unavailable for certain users.
Affected services
Updated
Mar 11, 2026 at 3:46am UTC
Our team has identified the affected S3 nodes and is rerouting traffic to healthy infrastructure while replacing and restoring the impacted components. We are also rebalancing load across regions to ensure stability and prevent further disruption. Service is gradually returning to normal, and we continue to monitor the system closely to ensure full recovery.
Affected services
Created
Mar 11, 2026 at 2:56am UTC
We are currently experiencing temporary slow performances affecting a subset of storage nodes. This may result in intermittent access issues or degraded performance for some users. Our team is actively investigating and working to restore full service as quickly as possible.
Affected services